Re: Need help about SUIF (Alex Martelli)
Fri, 27 Oct 1995 18:09:37 GMT

          From comp.compilers

Related articles
Need help about SUIF (1995-10-02)
Re: Need help about SUIF (1995-10-13)
Re: Need help about SUIF (1995-10-27)
| List of all articles for this month |

Newsgroups: comp.compilers
From: (Alex Martelli)
Keywords: interpreter
Organization: Cad.Lab Spa, Bologna, Italia
References: 95-10-040 95-10-079
Date: Fri, 27 Oct 1995 18:09:37 GMT (Seth M. LaForge) writes:
>I'm assuming you're trying to compile SUIF 1.0.1. You must use gcc
>2.5.8 to compile SUIF 1.0.1. Unfortunately much of the SUIF code was
>written before C++ was anywhere near standardized, and it violates
>privacy issues right and left (but gcc 2.5.8 allows the violations).

Note that later versions of gcc can also be invoked with specific
switches to allow all sorts of dirty stuff -- in particular, you
CAN tell gcc to treat everything as "public", if needed... I don't
recall the option keyword for that, but a quick browse on info
should tell you.

Email: Phone: +39 (51) 597313
CAD.LAB s.p.a., v. Ronzani 7/29, Casalecchio, Italia Fax: +39 (51) 597120


Post a followup to this message

Return to the comp.compilers page.
Search the comp.compilers archives again.